Is archive-R compatible with my version of Media Composer?

Yes.  archive-R has been tested with the latest version of Avid’s Media Composer; MC v2018.12 as of this posting.


« Back to the Knowledgebase
Posted in .